Announcement

Collapse

PMDG Forum Rules

1) SIGN YOUR POSTS. Since 1997, we have asked users to sign their real name, first and last, to all posts in the PMDG forum. We do this in order to keep conversations personal and familiar. You took the time to be here, we want to get to know you. This is one of the few rigid rules that we enforce regularly. We do so because we feel that forums in which users must engage one another personally are generally warmer, more collegial and friendly. Posts that are unsigned will be quietly removed without comment by the moderators, so to make your life easy- we recommend enabling your forum signature so that you never need to remember. Do this by clicking the username pull-down at the top right, then selecting "User Settings." You will find the signature editor on the ACCOUNT tab, about half way down the page. Look for "Edit Post Signature." Be sure to click the "Show Signatures" box.

2) BE NICE. We are all simmers here and no matter our differences of opinion, we share a common love of aviation, computing and simulation. Treat everyone else in the forum with respect even when you disagree. If someone frustrates you, walk away from the conversation or ask for a moderator to get involved. Speaking of Moderators, they prefer not to be treated as "The Thought Police" but if any behavior infringes on the enjoyment of another user or is otherwise considered to be unacceptable in the moderator's judgment, it will be addressed in keeping with our view of ensuring that this forum remains a healthy environment for all simmers.

3) BE LAWFUL: Any behavior that infringes upon the law, such as discussion or solicitation of piracy, threats, intimidation or abuse will be handled unsympathetically by the moderators. Threats and intimidation may, at the moderator's discretion, be provided to law enforcement for handling.

4) BE FACTUAL: When you post, always be factual. Moderators will remove posts that are determined not to be factually accurate.

5) RESPECT COPYRIGHTS: Posting of copyrighted material such as flight manuals owned by Boeing or various airlines is not allowed in this forum. If you have questions related to copyrighted material, please contact a forum moderator for clarification.

6) RESPECT PMDG: We love to hear what you like about our products. We also like to hear what you think can be improved, or what isn't working. Please do tell us and we will always treat your feedback with value. Just be sure to treat the team respectfully, as they do put a significant amount of effort into building and maintaining these great simulation products for you.

7) RESPECT PMDG DEVELOPERS: All of the developers will spend some time here. Given the ratio of developers-to-users, it simply isn't possible for us to answer every post and private message individually. Please know that we do try to read everything, but developer workload is simply too high to manage personal contact with tens-of-thousands of users simultaneously. In most cases, members of the development team will stick to conversations in the forum and will not answer private messages.

8) RESPECT OTHER DEVELOPERS: PMDG has always advocated for a strong development community and we have many friends within this community. Every developer offers something unique that helps to make the simming community larger and more vibrant. We insist that you treat our friends respectfully.

9) RESPECT MODERATORS: Moderators have a tough job, and none of them enjoy having to stomp out negativity. If a moderator has to weigh in to keep a thread peaceful, please respect that effort and refrain from giving the moderator any grief.

10) If you require official support for any of our products please open a support ticket through the support portal, https://support.precisionmanuals.com

11) This forum is designed primarily as a vehicle for the PMDG development team to interact with our customers, and for customers to interact with one another in a manner that is positive, supportive and assists in the general advancement of understanding the simulation and helping to make this and future simulations better. Any other use of this forum is not permitted, including but not limited to discussion of pricing policies, business practices, forum moderating policies, advertising of non-PMDG products, promotion of events, services or products that are not approved in advance by PMDG or any other topic deemed unacceptable by any forum administrator

12) HAVE FUN: This is the whole point of it all.
See more
See less

Migration from prepar3d v4.5 to v5.2 --- Check list

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Migration from prepar3d v4.5 to v5.2 --- Check list

    Hi folks,

    XMas is coming up and I might get a go from my government to migrate from prepar3d v4.5 to v5.2.

    1. I understand that all my PMDG aircraft work with both, v4.5 and v.5.2?
    2. I assume that I have to re-install all my PMDG aircraft again via the PMDG operations centre?
    3. Active Sky for prepar3d v4: I need a new version covering prepar3d v5 to have the weather radar screen experience, right.
    4. All the ORBX stuff needs to be re-installed as well into the prepar3d v5.2 directory, but I don't have to purchase everything again; correct?
    5. All other extra sceneries I have to link into p3d v5.2 via Scenery as usual.
    6. AI traffic (e.g. alpha-india) on top...

    Have I anything forgotten?

    Thanks in advance.
    Andre(as) Berg --- i7 8700K 12MB 3.7G. MSI Z370 Tomahawk. DDR4 16G. SSD 500G M.2. MSI RTX2080 DUKE 8G

    #2
    A. Yes, PMDG aircraft works with both V4 and V5.
    B. You do have to reinstall your PMDG aircraft, but not via the Operations Center. You uninstall via the Windows Control Panel, and then you run the installer that you downloaded when you installed it. It should ask you which simulators you want to install it. If it doesn't, you may have an old installer, in which case you can get a new one by going into your PMDG store account.
    C. Yes. It is Active Sky P3D that you need. Their website should make it clear which one is for V4 and V5.
    D. This is correct.
    E. I'd make sure the scenery was P3D V5 compatible first. Some developers haven't made their scenery compatible with V5 yet.
    F. I can't help you there.
    Captain Kevin

    Kevin Yang

    Comment


    • 19ab67
      19ab67 commented
      Editing a comment
      Thx, Kevin!

    #3
    Originally posted by 19ab67 View Post
    Hi folks,

    XMas is coming up and I might get a go from my government to migrate from prepar3d v4.5 to v5.2.

    1. I understand that all my PMDG aircraft work with both, v4.5 and v.5.2?
    2. I assume that I have to re-install all my PMDG aircraft again via the PMDG operations centre?
    3. Active Sky for prepar3d v4: I need a new version covering prepar3d v5 to have the weather radar screen experience, right.
    4. All the ORBX stuff needs to be re-installed as well into the prepar3d v5.2 directory, but I don't have to purchase everything again; correct?
    5. All other extra sceneries I have to link into p3d v5.2 via Scenery as usual.
    6. AI traffic (e.g. alpha-india) on top...

    Have I anything forgotten?

    Thanks in advance.
    In addition to Kevin's correct response:
    1. You need the latest installers for PMDG products. The OC can verify if you already have them.
    2. What Kevin said.
    3. Affirmative
    4. This is easier than I expected. The key here is to create a Library for all of your P3Dv5 Orbx products on a data drive where you have room, then each product is installed into the library by Orbx Central and easy to keep up to date. The installation uses add-on.cfg Discovery Paths, which you do not need to know anything about. It's all very easy.
    5. For the most part, I simply copied the add-on.xml files I used in v4 to the P3D Addons folder in Documents for v5. If you used the legacy method (scenery.cfg entries) then it's a lot harder. About 5% of my 120+ sceneries didn't make it to v5. About 25% have new installers from the developers for v5. If there is an update use it because things changed in v5 regarding airport elevations.
    6. No AI traffic allowed on my machine.

    The performance and rendering quality is v5 is worth the effort. Glad your legislature has passed this bill.
    Dan Downs KCRP
    i7-10700K 32GB 3600MHz 2080Ti

    Comment


    • 19ab67
      19ab67 commented
      Editing a comment
      Successful lobbying...
      8^*
      8^D
      Last edited by 19ab67; 02Nov2021, 09:46.

    #4
    There is one aircraft yet to be migrated to V5 and that is the DC6. I understand it’s coming.
    Victor Green

    Comment


      #5
      Originally posted by Lanica View Post
      There is one aircraft yet to be migrated to V5 and that is the DC6. I understand it’s coming.
      Is it? I've seen posts about porting the current DC-6 to v5. Is an official v5 version coming?
      Andrew Hill
      i9-9900KS 64GB Dual RTX 2080 Super
      P3D V5 & MSFS 2020

      Comment


      • 19ab67
        19ab67 commented
        Editing a comment
        Hello, my namesake, Andrew Hill... Hill (eng.) = Berg (german). 8^D

      #6
      I removed V4.4 to install 5 and ive yet to do it and that was august. Not because MFS is better, my wife just had a baby so i dont have time. Ill prob stick with MFS
      Jason McAree - EICK

      Comment


        #7
        Originally posted by CaptainSkidmark View Post
        ........my wife just had a baby so i dont have time. Ill prob stick with MFS
        there goes your investments....... enjoy "parenting" ('tis more rewarding than playing with a computer)
        cheers
        john martin

        Comment


          #8
          Originally posted by Hilly32 View Post

          Is it? I've seen posts about porting the current DC-6 to v5. Is an official v5 version coming?
          According to Robert they are using the DC6 to experiment with back compatibility from MSFS to P3DV5. Probably not soon with everything else in the oven right now. I know some have installed the DC6 into V5 by some how fooling the installer.
          Victor Green

          Comment


            #9
            Originally posted by Lanica View Post

            According to Robert they are using the DC6 to experiment with back compatibility from MSFS to P3DV5. Probably not soon with everything else in the oven right now. I know some have installed the DC6 into V5 by some how fooling the installer.
            Ups, reading the PMDG.com page regarding the DC6, yes, it is not released for v5.

            [MOD EDIT] Asking how to install on a none supported platform is not allowed. Any answers regarding this will be removed.
            Andre(as) Berg --- i7 8700K 12MB 3.7G. MSI Z370 Tomahawk. DDR4 16G. SSD 500G M.2. MSI RTX2080 DUKE 8G

            Comment


              #10
              Originally posted by vadriver View Post

              there goes your investments....... enjoy "parenting" ('tis more rewarding than playing with a computer)
              Ahhhch, I just bought a second HD to install P3d V5 on. should have it by monday. I have all my Airports and Aircraft etc downloaded today so just need to install the drive and install P3D on the second HD as FS is taking up 35% of the main HD so ill split them out. Otherwise ill be up to 60%
              Jason McAree - EICK

              Comment


                #11
                Great post, I'll be saving for {just i case I switch over }, me and my friend have been simming since the 90's and have upgraded and upgraded over the years and have both decided in our 70's we've had enough and are gonna stay with P3d no matter how good the new Microsoft sim is, aside from the fact no way an i paying fees for it . But what were checking right now is it worth the move from P3dv4.5 to P3d 5, and don't have a concrete answer yet .
                Louis Massicotte - Alberta

                Comment


                  #12
                  Originally posted by Captain Kevin View Post
                  A. Yes, PMDG aircraft works with both V4 and V5.
                  B. You do have to reinstall your PMDG aircraft, but not via the Operations Center. You uninstall via the Windows Control Panel, and then you run the installer that you downloaded when you installed it. It should ask you which simulators you want to install it. If it doesn't, you may have an old installer, in which case you can get a new one by going into your PMDG store account.
                  C. Yes. It is Active Sky P3D that you need. Their website should make it clear which one is for V4 and V5.
                  D. This is correct.
                  E. I'd make sure the scenery was P3D V5 compatible first. Some developers haven't made their scenery compatible with V5 yet.
                  F. I can't help you there.
                  Responding to a number list with alphabet...classic.
                  Gabriel Guzman- IAH "Never stop flying the plane."
                  My ANA 777 fleet project

                  Comment


                    #13
                    Originally posted by CaptainGabe View Post
                    Responding to a number list with alphabet...classic.
                    I mean, it IS me we're talking about here. Shouldn't be too much of a surprise, really.
                    Captain Kevin

                    Kevin Yang

                    Comment

                    Working...
                    X